annuncio

Comprimi
Ancora nessun annuncio.

Problema gimbal basecam

Comprimi
X
  • Filtro
  • Ora
  • Visualizza
Elimina tutto
nuovi messaggi

  • Problema gimbal basecam

    Buon giorno a tutti.
    come da titolo ho un curioso problema al gimbal basecam montato sul mio F450.
    Premetto che il gimbal è alimentato dalla batteria del drone (3S 40C).
    All'accensione esegue correttamente l'autocalibrazione e si posiziona con la camera orizzontale. A questo punto sembra che tutto funzioni perfettamente. La camera resta perfettamente orizzontale contrastando qualsiasi movimento del drone anche piuttosto repentino eseguendo brusche variazioni di assetto muovendolo con le mani.
    Porto il drone in volo e dopo circa cinque minuti il gimbal inizia a sfarfallare muovendo la telecamera a scatti come se avesse perso i parametri del giroscopio.
    Riporto il drone a terra, spengo e riaccendo il tutto ma il gimbal non riparte più. Non esegue più l'autocalibrazione e la telecamera resta inclinata da un lato.
    Torno a casa, controllo verifico e riguardo tutto senza trovare nulla di stano. Riaccendo tutto e stranamente funziona.
    Provo a fare un volo giù al box e tutto va bene...prova anche a volare in soggiorno (destando l'apprensione di mia moglie!!!) e tutto funziona.
    Provo quindi ad aumentare la potenza dei motori portando il parametro a 150. Carico la batteria e torno all'aperto a riprovare.
    Porto in volo il drone e dopo cinque minuti di volo succede la stessa cosa...il gimbal è morto!!!!
    Torno a casa e questo maledetto torna a funzionare!!!!!
    Ma che cavolo succede?....Provo a sbatacchiarlo in modo più o meno violento per provocare qualche reazione strana...ma questo funziona benissimo.....
    Non saprei proprio....voi che ne pensate?

  • #2
    Ciao.
    A me succedeva la stessa cosa per un connettore ossidato.
    Prova a pulirli con dello spray per contatti elettrici.
    In particolare quello del sensore di posizione.
    Blade Chroma***Xk Detect X380-C***Drocon Bugs 6

    Commenta


    • #3
      Ed eventualmente controlla le saldature.
      Blade Chroma***Xk Detect X380-C***Drocon Bugs 6

      Commenta


      • #4
        Io ho avuto un comportamento simile con il Basecam, quando pilotavo il pitch dalla radio. La ragione era nella instabilita' del contatto sul segnale di comando del pitch. Ballava e se per una virata o per il vento per un attimo perdeva il contatto, il gimbal impazziva o non andava piu' del tutto. A terra tutto bene.
        Ho risolto inserendo dei trefoli di rame nella femmina, in modo da stabilizzare il contatto. Da allora tutto perfetto.
        JJRC H8C / Bayangtoys X9/Eachine Wizard X220/Eachine QX65
        Phantom 1.1.1, gimbal, SJ4000 e Gitup GIT2
        Eachine ET526 / Eachine LCD5800D 5.8GHz 40Ch FPV

        Commenta


        • #5
          Grazie per le risposte.
          Volevo aggiungere che dopo qualche prova effettuata collegando il gimbal al PC ho notato che si verificavano numerosi errori sulla I2C.
          Ho spuntato la casella "I2C pullups enable" e sembra che gli errori siano diminuiti in modo molto evidente.
          Comunque quello che dice gianni_BT è interessante perché non ho provato a fare un volo senza collegare la ricevente al gimbal.
          Proverò e vi terrò aggiornati.

          Commenta


          • #6
            Allora.....ho fatto come da voi suggerito, ovvero controllato i contatti sul gimbal e sulla ricevente ed in effetti non erano un granchè...specialmente i cavetti che vanno dalla ricevente al gimbal.
            Ho quindi sistemato il tutto ed eseguito un volo di 10 minuti ed è andato tutto perfettamente.
            Devo dire che è venuta una discreta ripresa aerea con un grado di stabilità accettabile.
            Il gimbal ha funzionato bene senza nemmeno un incertezza.
            Forse qualche vibrazione leggera, ma quel giorno c'era un moderato vento con leggera turbolenza ed il drone ha lavorato parecchio per restare livellato per cui penso che ci si possa stare.

            Grazie a tutti per le risposte.

            Commenta


            • #7
              Felice che tu abbia risolto
              Blade Chroma***Xk Detect X380-C***Drocon Bugs 6

              Commenta


              • #8
                Originariamente inviato da benedetto Visualizza il messaggio
                Allora.....ho fatto come da voi suggerito, ovvero controllato i contatti sul gimbal e sulla ricevente ed in effetti non erano un granchè...specialmente i cavetti che vanno dalla ricevente al gimbal.
                Ho quindi sistemato il tutto ed eseguito un volo di 10 minuti ed è andato tutto perfettamente.
                Devo dire che è venuta una discreta ripresa aerea con un grado di stabilità accettabile.
                Il gimbal ha funzionato bene senza nemmeno un incertezza.
                Forse qualche vibrazione leggera, ma quel giorno c'era un moderato vento con leggera turbolenza ed il drone ha lavorato parecchio per restare livellato per cui penso che ci si possa stare.

                Grazie a tutti per le risposte.
                Da quanto dici, e' molto probabile che il problema fosse simile a quello riscontrato da me.
                Io ho stabilizzato il contatto, mantenedo l'estraibilita', inserendo nella femmina qualche trefolo di filo di rame, in modo che l'inserzione fosse un po' forzata: da allora problemi zero.
                E' comunque un po' strana la storia degli errori su I2C: col mio siamo sempre ad errori zero anche senza attivare le resistenze di pull-up.
                Anche in questo caso controlla bene, eventualmente con una lente di ingrandimento, che tutti i pin sulla IMU siano inseriti bene e che non ci siano tagli anche minimi sui microscopici fili che collegano la IMU alla scheda della gimbal.
                JJRC H8C / Bayangtoys X9/Eachine Wizard X220/Eachine QX65
                Phantom 1.1.1, gimbal, SJ4000 e Gitup GIT2
                Eachine ET526 / Eachine LCD5800D 5.8GHz 40Ch FPV

                Commenta


                • #9
                  Visto che l'ho appena fatto, approfitto per condividere il video che ho realizzato e che mostra quanto ho descritto in precedenza.
                  Spero possa essere da spunto per ulteriori scambi di opinioni.

                  https://youtu.be/tmXEkMzLRgY

                  Commenta


                  • #10
                    Originariamente inviato da benedetto Visualizza il messaggio
                    Visto che l'ho appena fatto, approfitto per condividere il video che ho realizzato e che mostra quanto ho descritto in precedenza.
                    Spero possa essere da spunto per ulteriori scambi di opinioni.

                    https://youtu.be/tmXEkMzLRgY
                    Hai un effetto di tremolio piuttosto marcato che si vede sia sulle chiome degli alberi ma, soprattutto, sulla zampa del quadricottero.
                    Potrebbe essere dovuto ad uno sbilanciamento delle eliche.
                    Si sente pero' in sottofondo un rumore diverso da quello dei motori, che potrebbe indicare un continuo tentativo della gimbal di mantenere la posizione.
                    Proverei a dare una controllata ai parametri della gimbal, in particolare ai PID e ai parametri di power.
                    Ti allego i miei settaggi che sono fatti per una Gitup Git2 (uguale ad una Gopro 3).
                    Per il bilanciamento delle eliche devi montarle su un perno e appoggiarle ad es. ad un bicchiere messo in piano: l'elica non deve ruotare. Se ruota metti un pezzettino di nastro dalla parte opposta a quella in cui ruota, finche' la rotazione spontanea si arresta.
                    File allegati
                    JJRC H8C / Bayangtoys X9/Eachine Wizard X220/Eachine QX65
                    Phantom 1.1.1, gimbal, SJ4000 e Gitup GIT2
                    Eachine ET526 / Eachine LCD5800D 5.8GHz 40Ch FPV

                    Commenta


                    • #11
                      Mi sono accorto che gli allegati non si vedono, anche se ho tentato di aggiustarli come da indicazione nell'area generale.
                      Se ti interessa, li ritrovi al post #1705 di questa discussione

                      https://www.dronerc.it/forum/forum/c...-da-90/page114
                      JJRC H8C / Bayangtoys X9/Eachine Wizard X220/Eachine QX65
                      Phantom 1.1.1, gimbal, SJ4000 e Gitup GIT2
                      Eachine ET526 / Eachine LCD5800D 5.8GHz 40Ch FPV

                      Commenta


                      • #12
                        Ciao, sie le eliche che le casse dei motori sono state equilibrate. Credo che il tremolio sia dovuto principalmente al vento ella turbolenza che quel giorno non era poi così leggera.
                        Dico questo perché da una prova che ho fatto effettuando un volo di prova giù di fronte al box e quindi in totale assenza di vento, l'immagine non presentava tremolio.
                        Riguardo al discorso PID, credo che ci si debba ancora lavorare e come ben sappiamo è un lavoro lungo e tedioso.

                        Commenta


                        • #13
                          Originariamente inviato da benedetto Visualizza il messaggio
                          Ciao, sie le eliche che le casse dei motori sono state equilibrate. Credo che il tremolio sia dovuto principalmente al vento ella turbolenza che quel giorno non era poi così leggera.
                          Dico questo perché da una prova che ho fatto effettuando un volo di prova giù di fronte al box e quindi in totale assenza di vento, l'immagine non presentava tremolio.
                          Riguardo al discorso PID, credo che ci si debba ancora lavorare e come ben sappiamo è un lavoro lungo e tedioso.
                          Ho qualche dubbio. Il tremolio da vento si traduce in uno sbandamento improvviso, mentre il tuo video aveva un effetto jjello(vibrazione continua ad alta frequenza) che potrebbe essere dovuto, ad esempio, ad una potenza insufficiente al motore di pitch per controbattere le resistenza all'avanzamento.
                          Puo' anche essere il contrario, ovvero troppa potenza al motore che sta fermo in condizioni stabili, ma appena affronta una resistenza, comincia a muoversi, il controller cerca di riportarlo in posizione e cosi' via.
                          Un modo molto approssimativo per vedere se o la potenza motori o ii pid sono ragionevolmente a posto, si puo' fare in casa, senza eliche.
                          Si accende il tutto, lo si lascia stabilizzare, poi si da' un colpetto con un dito alla camera, di fronte per testare il pitch, su un angolo per testare il roll: la camera deve offrire una certa resistenza e deve tornare in posizione rapidamente e senza fare oscillazioni.
                          Questo tuning grossolano evita' pero' di dover impiegare ore per fare il tuning, testarlo in volo etc.
                          Il segreto e' quello di rifare la stessa prova muovendo 1 solo parametro(partendo dal proporzionale o dalla potenza motori) a passi ragionevolmente piccoli(diciamo 10%) fino a trovare il valore che crea l'instabilita', dopo di che si torna indietro un 10/15 %: di solito si ottiene un risultato discreto per tutte le situazioni.
                          JJRC H8C / Bayangtoys X9/Eachine Wizard X220/Eachine QX65
                          Phantom 1.1.1, gimbal, SJ4000 e Gitup GIT2
                          Eachine ET526 / Eachine LCD5800D 5.8GHz 40Ch FPV

                          Commenta

                          Sto operando...
                          X