annuncio

Comprimi
Ancora nessun annuncio.

quad che non decolla...

Comprimi
X
  • Filtro
  • Ora
  • Visualizza
Elimina tutto
nuovi messaggi

  • quad che non decolla...

    Ciao a tutti!

    ho da poco terminato di assemblare un quadricottero. Non è il primo che realizzo ma con questo ho un problema a cui non riesco a venire a capo.

    Il quad è basato su una FC Kakute F4v2, ESC HAKRC BLHeli_32 e motori emax MT1806.
    Radio Frsky X-Lite S con rx XM+.

    Provato il quad sul banco tutto è ok: le varie schede di Betaflight riportano valori corretti, la rx invia correttamente la posizione degli stick.
    Anche testando i motori via software tutto ok: portando a 2000ms il segnale di throttle la rotazione dei motori è costante.

    I problemi nascono nella prova sul campo: appena do gas, i motori iniziano a girare ad un buon rate ma dopo qualche istante perdono "potenza"... addirittura non lo fanno in maniera uniforme ma random (a volte un motore rimane al max numero di giri mentre gli altri 3 calano...).

    Ho provato a ri-flashare gli ESC, a cambiare protocollo (da DSHOT1200 scendendo a 600...) ma non migliora nulla. Anche il cambio batterie (3S, 4S, nuova...) non sembra sortire effetti.

    Vi allego un dump blackbox che illustra un esempio di comportamento anomalo: quad orizzontale, stick throttle fisso al massimo e 3 motori su 4 che iniziano a girare + lentamente...
    Da cosa può dipendere secondo voi?

    grazie mille!
    File allegati

  • #2
    Se mettevi il log invece di un filmato era meglio!!!!
    Così come dici posso solo immaginare che la I dei PID controller stia intervenendo perchè fermo a terra (immagino che non ci siano eliche durante quella prova, vero???) e che, quindi, stia provando a correggere quel piccolissimo errore sempre presente!!!!

    Commenta


    • #3
      Ciao!

      hai ragione, ecco il log completo del test.
      Ti confermo che la prova è stata fatta senza eliche, ma il problema si presenta anche con le eliche montate (non riesco a decollare perché appena do gas i motori non "spingono" in maniera uniforme)

      grazie!
      File allegati

      Commenta


      • #4
        su betaflight, il quad (quello nel modello 3d) é mostrato dritto oppure sottosopra???
        perché normalmente la z é negativa ma qui é positiva!!!
        comunque confermo che sono la I dei pid... log con eliche sopra please!!!
        Ultima modifica di BBC25185; 09 novembre 19, 21:20.

        Commenta

        Sto operando...
        X