annuncio

Comprimi
Ancora nessun annuncio.

Problema con SPRACING F3 Mini e Cleanflight.

Comprimi
X
  • Filtro
  • Ora
  • Visualizza
Elimina tutto
nuovi messaggi

  • Problema con SPRACING F3 Mini e Cleanflight.

    Un saluto a tutti
    Ho un quad 250 con scheda SPRACING F3 Mini e Cleanflight.
    Succede, da sempre, e con più firmware compreso il più recente, che quando do direzionale il quad oltre a ruotare su sé stesso cambia anche beccheggio, col risultato di non ruotare sul posto (e non ruotare rispetto all'asse verticale) ma comincia a deviare. L'effetto è tanto più marcato quanto più velocemente ruoto.
    Ho provato il quad al banco, poggiato su un piano, senza batterie e solo collegato al PC tramite Cleanflight Configurator: se all'inizio vedo riportati gli angoli di pitch e roll attorno allo zero, se faccio ruotare il quad e poi mi fermo (rimanendo in piano) mi ritrovo con il pitch che cambia anche fino a 2°, per poi tornare attorno allo zero lentamente (3-4 secondi).
    Da ciò suppongo che sia un problema hardware, o relativo a qualche parametro firmware che però non riesco ad individuare.
    Ovviamente ho già provato a resettare completamente la scheda senza risultato.
    A qualcuno è mai successo?

    Massimo
    http://www.aeromodellistipiovesi.it/

  • #2
    La butto li: non è che ci sia qualche comando o spunta che attiva la miscelazione tra i canali (mixer)?
    Ultima modifica di Pier2162; 04 dicembre 18, 19:14.
    Blade Chroma*Xk Detect X380-C

    Commenta


    • #3
      Anche fosse, nel cleanflight configurator, non riesco a trovarla... ma non mi sembra un comportamento da miscelazione, sembra più (se è software) una qualche compensazione strana.
      Assomiglia ad un "allineamento scheda sensori" errato, ma nel mio caso ho scheda in piano col telaio e in cleanflight è impostato tutto a 0.
      http://www.aeromodellistipiovesi.it/

      Commenta


      • #4
        Originariamente inviato da max_ferra Visualizza il messaggio
        Anche fosse, nel cleanflight configurator, non riesco a trovarla... ma non mi sembra un comportamento da miscelazione, sembra più (se è software) una qualche compensazione strana.
        Assomiglia ad un "allineamento scheda sensori" errato, ma nel mio caso ho scheda in piano col telaio e in cleanflight è impostato tutto a 0.
        Se mastichi un po' di inglese prova a dare un'occhiata a questa guida
        https://github.com/cleanflight/clean.../docs/Mixer.md
        Assicurati inoltre che la funzione mix non sia impostata nella radio, dato che dici che è proporzionale al movimento degli stick.
        Ultima modifica di Pier2162; 05 dicembre 18, 08:27.
        Blade Chroma*Xk Detect X380-C

        Commenta


        • #5
          Originariamente inviato da Pier2162 Visualizza il messaggio

          Se mastichi un po' di inglese prova a dare un'occhiata a questa guida
          https://github.com/cleanflight/clean.../docs/Mixer.md
          Assicurati inoltre che la funzione mix non sia impostata nella radio, dato che dici che è proporzionale al movimento degli stick.

          Nella radio non ho mix attivi (nei comandi) e il doc che citi riguarda i mix in uscita.
          Il mio problema, secondo me, riguarda il giroscopio e la relativa lettura del dato.
          Il "difetto" non è direttamente proporzionale allo stick, ma alla velocità di movimento: quando dicevo di averlo provato al banco solo collegato al PC intendevo con radio spenta e solo la FC alimentata: in quelle condizioni se faccio ruotare la scheda sull'asse verticale vedo che il pitch sbaglia fino ed oltre 2 gradi, per poi tornare a zero lentamente, mentre il roll rimane intorno allo zero.

          http://www.aeromodellistipiovesi.it/

          Commenta


          • #6
            Ma te lo fa ruotando la scheda da entrambi i lati?
            Blade Chroma*Xk Detect X380-C

            Commenta


            • #7
              Originariamente inviato da Pier2162 Visualizza il messaggio
              Ma te lo fa ruotando la scheda da entrambi i lati?
              Si!
              Proverò a recuperare un'altra scheda, vediamo come va.
              Massimo
              http://www.aeromodellistipiovesi.it/

              Commenta


              • #8
                A questo punto di può solo pensare alla scheda difettosa.
                Blade Chroma*Xk Detect X380-C

                Commenta

                Sto operando...
                X