annuncio

Comprimi
Ancora nessun annuncio.

ZMR250 F3 si flippa quando do colpi di throttle

Comprimi
X
  • Filtro
  • Ora
  • Visualizza
Elimina tutto
nuovi messaggi

  • ZMR250 F3 si flippa quando do colpi di throttle

    Ho appena terminato la costruzione del mio ZMR250.

    Ho trapiantato i motori KingKong 2300kV cosi come gli ESC da 12A con firmware BlHeli 14.8

    FC: SPRacing F3
    PDB: Matek HUB OSD

    Il problema è che decollo senza problemi, sto in hovering, appena aumento il gas diciamo sopra il 50-60% il quad si capovolge e cade a terra. E' come se si spegnesse il motore anteriore destro ovvero il 2
    Questo accade sia in Angle, che Horizon che rate..

    Ho già calibrato tutto, la FC, gli ESC.
    Non sento l' ESC riavviarsi quindi escluso falsi contatti tra il cavo esc e la FC
    Non riesco a capire cosa possa essere..

    Mi potete aiutare?

  • #2
    Non posso più editare, mi scuso per il doppio post.

    Dalla blackbox si vede che viene dato il comando al motore di spingere, cosa che lui non fa.

    Quindi le opzioni sono poche:
    - esc sta morendo
    - motore sta morendo
    - perdita di sync tra ESC e motore

    Purtroppo dopo aver saldato tutto mi son reso conto che tutti i motori giravano al contrario, non avendo voglia di smontare e risaldare tutto ho impostato il "Reverse" in BLHeli su ogni ESC.

    Non so se questo può creare problemi

    Commenta


    • #3
      Prima di tutto controllerei che i motori abbiano i filetti delle eliche a stringere quando girano, potresti avere un'elica (o due) che quando acceleri slitta.



      Umberto
      There is much goodness with the vertical as far aft as possible to minimize yaw excursions (maximize yaw damping).
      JW

      Commenta


      • #4
        Originariamente inviato da milan Visualizza il messaggio
        Prima di tutto controllerei che i motori abbiano i filetti delle eliche a stringere quando girano, potresti avere un'elica (o due) che quando acceleri slitta.



        Umberto
        Grazie del suggerimento, ma sono certo di aver stretto bene. Uso una chiave per stringere i dadi.. e verifico che non slittino.

        Analizzando la blackbox mi è venuto un dubbio, per cui ho cercato e ho letto di Desync dovuti al "Reverse" di BLHeli.
        Ho quindi aperto i termorestringenti di ogni esc, staccato il motore, invertiti i cavi per la rotazione.
        Domani faccio una prova

        Una prima prova l'ho fatta con un solo motore e sembrava aver risolto i problemi di quel motore, ma andavano in desync gli altri quindi flippava comunque il quad.

        Domani pomeriggio provo e vi faccio sapere

        Commenta


        • #5
          Probabilmente non sta lì il problema ma anche io ti consiglio di non usare il reverse di bheli ma di invertire il senso di rotazione a livello hardware...

          Comunque non è che sia un problema di calibrazione degli Esc? Eventualmente rifai la calibrazione....
          -----------------------------------------------------------------------

          Gam-Gam-Gam Ki Elech, Be-Beghe Tzalmavet, Lo-Lo-Lo, Ira Ra, Ki Atta Immadì, Shivtechà umishantechà, Hema-Hema yenachamuni....

          Commenta


          • #6
            Originariamente inviato da klamath Visualizza il messaggio
            Probabilmente non sta lì il problema ma anche io ti consiglio di non usare il reverse di bheli ma di invertire il senso di rotazione a livello hardware...

            Comunque non è che sia un problema di calibrazione degli Esc? Eventualmente rifai la calibrazione....
            Ho invertito i cavi e provato poco fa.. ma non ho risolto.

            Perde il sync l' esc con il motore.. ma visto che non lo faceva con la CC3D e Librepilot evidentemente c'è qualcosa che mi sfugge in Cleanflight che non conosco bene)

            Ho ricalibrato gli ESC ma ancora niente..

            Commenta


            • #7
              Settando da BLHeli il Motor Timing in alto (era medio prima) migliora la situazione.. ma rimane il problema, principalmente sul motore 3 e 1.

              Sto pensando al Demag Compensation.. può essere utile metterlo in High?


              Il throttle minimo è a posto, i motori senza eliche girano senza alcun rumorino di stuttering.

              I PID sono quelli stock di Cleanflight con controller LuxFloat, ma non credo sia un problema di questo tipo.. e sono:
              P I D Rate
              40 30 23 0.70 ROLL
              40 30 23 0.60 PITCH
              85 45 0 2.55 YAW

              20 10 75 Angle

              Sbaglio o sono un po' alti?
              Ultima modifica di L4kyITA; 01 febbraio 17, 15:53.

              Commenta


              • #8
                Direi che abbiamo un verdetto.

                Dopo aver aumentato il demag compensation ad High il problema pare decisamente ridotto su 3 motori.

                Uno invece continua ad avere problemi e stuttera. Avevo un motore di ricambio, l'ho risaldato al volo e va ancora peggio.

                A sto punto penso sia l' ESC morto... si scalda più degli altri.

                Ma com'è possibile che muoia così? Non ho fatto nulla, l'ho semplicemente trapiantato dal vecchio al nuovo quad..


                Mi scuso per i post consecutivi di nuovo

                Commenta


                • #9
                  In arrivo DYS XS30A e Emax RS2205 red bottom..

                  Magari in futuro mi ricostruisco il kingkong con tutta la sua roba ( visto che oramai ho cambiato tutto ), compro un paio di esc e di motori ( visto quel che costano ) e lo uso come drone da destruction derby

                  Commenta


                  • #10
                    Originariamente inviato da L4kyITA Visualizza il messaggio
                    Direi che abbiamo un verdetto.

                    Dopo aver aumentato il demag compensation ad High il problema pare decisamente ridotto su 3 motori.

                    Uno invece continua ad avere problemi e stuttera. Avevo un motore di ricambio, l'ho risaldato al volo e va ancora peggio.

                    A sto punto penso sia l' ESC morto... si scalda più degli altri.

                    Ma com'è possibile che muoia così? Non ho fatto nulla, l'ho semplicemente trapiantato dal vecchio al nuovo quad..


                    Mi scuso per i post consecutivi di nuovo
                    Un consiglio per quando si saldano componenti elettronici delicati tipo circuiti integrati o schede che li contengono: utilizzare saldatori a gas oppure staccare la spina per il tempo necessario a fare la saldatura.
                    A volte i saldatori elettrici non sono ben isolati e può succedere di avere una parte di fase a 230v sulla punta, la tensione si scarica sulla scheda al contatto danneggiando irreparabilmente i sopracitati componenti.
                    Chi ha lavorato come me con i cmos sa che anche l'elettricità statica di un maglione sintetico può danneggiarli e si utilizzano braccialetti di massa per scaricare a terra anche questa...
                    Blade Chroma***Xk Detect X380-C***Yuneec Typhoon H

                    Commenta

                    Sto operando...
                    X