annuncio

Comprimi
Ancora nessun annuncio.

Motori / esc sbilanciati

Comprimi
X
  • Filtro
  • Ora
  • Visualizza
Elimina tutto
nuovi messaggi

  • Motori / esc sbilanciati

    Buona sera, dopo una miriade di tentativi ho deciso di chiedere aiuto qui sul forum alla ricerca di una soluzione.

    Di seguito la mia configurazione:

    - NAZE32 / MATEK F405 CTR

    - ESC FAVOURITE BL_S LITEBEE SPRING 30A

    - MOTORI RACESTAR SPROG X 2205 2300KV

    - RICEVENTE XM+

    - RADIO TARANIS QX7

    Volo con i droni da un anno ormai usando sempre il PWM come protocollo (inizialmente usavo la CC3D ma viste le sue limitazioni sono passato dopo poco al NAZE 32).
    Due settimane fa ho deciso di cambiare protocollo degli esc (da PWM a ONESHOT) apro cleanflight, imposto il nuovo protocollo ma quando sono andato a collegare la batteria gli esc hanno emesso la classica melodia di calibrazione, da quel momento i motori non girano all'unisono; ho provato a tornare al protocollo PWM ma niente,ho provato a calibrare l'accelerometro, ho provato a ricalibrare gli esc tramite cleanflight, ho provato tramite BLHELISUITE (aggiornando firware,verificando il master e gli slave, e tentando una calibrazione anche li), ho provato a cambiare gli esc (stesso modello), ho provato a cambiare flightcontroller (f405 provando a mettere il DSHOT visto che è supportato dagli ESC ma niente), ho provato a cambiare ricevente (sempre xm+) e persino i motori..... nessun cambiamento.
    La cosa strana è che dal configuratore cleanflight o betaflight quando vado a far girare i motori partono correttamente; mentre se li faccio partire con la radio si vede chiaramente dal grafico che girano ognuno per fatti propri.
    Ho cambiato ogni pezzo, potrebbe essere la radio ? preciso che ho provato a fare un nuovo profilo ma da sempre quel problema.......non so più che provare, spero ci sia qualcuno in grado di aiutarmi, grazie in anticipo.

  • #2
    Dimenticavo, se si da un colpetto di accelleratore i motori continuano ad accelerare da soli anche riposrtando lo stick al minimo , ho fatto un video per rendere meglio l'idea.
     

    Commenta


    • #3
      Riesci a fare una prova in esterno con le eliche montate? ovviamente in spazio aperto e dopo aver verificato il failsafe, meglio se associato ad uno switch che puoi attivare rapidamente(al limite basta il disarmo), facendo movimenti molto ridotti.
      La ragione per cui te lo dico e' che con la mia Nazam V2 ( ma anche con la SPracing F3, in modo meno evidente) il comportamento a banco senza eliche e' bizzarro.
      Se usi le simulazioni, tutto OK, ma quando usi la radio sembra che i motori vadano a caso. ritengo sia perche' anche con una minima correzione, non vedendo risposta, la FC tenta di dare correzioni che non possono evidentemente essere attuate.
      Se non ricordo male, c'era anche un video di Jushua baldwell che riportava queste considerazioni.
      JJRC H8C / Bayangtoys X9/Eachine Wizard X220/Eachine QX65
      Phantom 1.1.1, gimbal, SJ4000 e Gitup GIT2
      Eachine ET526 / Eachine LCD5800D 5.8GHz 40Ch FPV

      Commenta


      • #4
        Ti ringrazio per la risposta Gianni, una prova con le eliche montate l'ho già fatta ma in casa (lo so è pericoloso) tenendo il drone boccato a terra dall'alto con una mano e con l'altra dando gas, rimane fortemente sbilanciato anche trimmando la radio e se vado ad allentare la presa sul drone tende a rovesciarsi , le frequenze giroscopio/accellerometro non le ho toccate....pid sono quelli stock
        Proverò nuovamente ma questa volta gli lascerò fare il movimento che vuole e proverò a riprenderlo in video.

        Commenta


        • #5
          Originariamente inviato da gianni_BT Visualizza il messaggio
          Riesci a fare una prova in esterno con le eliche montate? ovviamente in spazio aperto e dopo aver verificato il failsafe, meglio se associato ad uno switch che puoi attivare rapidamente(al limite basta il disarmo), facendo movimenti molto ridotti.
          La ragione per cui te lo dico e' che con la mia Nazam V2 ( ma anche con la SPracing F3, in modo meno evidente) il comportamento a banco senza eliche e' bizzarro.
          Se usi le simulazioni, tutto OK, ma quando usi la radio sembra che i motori vadano a caso. ritengo sia perche' anche con una minima correzione, non vedendo risposta, la FC tenta di dare correzioni che non possono evidentemente essere attuate.
          Se non ricordo male, c'era anche un video di Jushua baldwell che riportava queste considerazioni.
          Ho provato nuovamente con le eliche e provando a ritrimmare da zero, nisba, il problema persiste.Si ribalta rendendolo di fatto inutilizzabile.
          Ho provato a vedere il video di Jushua (quello in cui aiutava un ragazzo di colore in live stream) e ho fatto tutte le cose che hanno fatto loro ma non è cambiato nulla.Grazie comunque.

          Commenta

          Sto operando...
          X