annuncio

Comprimi

Riattivazione del Mercatino

Abbiamo riattivato il mercatino, tutte le informzioni in questo post.

https://www.dronerc.it/forum/forum/d...-del-mercatino
Visualizza altro
Visualizza di meno

MegaPirate su CRIUS AIO Pro - Installation log

Comprimi
X
  • Filtro
  • Ora
  • Visualizza
Elimina tutto
nuovi messaggi

  • MegaPirate su CRIUS AIO Pro - Installation log

    Sul tema MegaPirate ho visto che ci sono un paio di thread interessanti:

    http://www.baronerosso.it/forum/mode...-settaggi.html

    http://www.baronerosso.it/forum/mode...gapirates.html

    dove ho trovato un sacco di informazioni utili e che consiglio di leggere a chi si vuole avvicinare a questo tema.

    Vista l'ampia disponibilità della scheda CRIUS AIO PRO a basso prezzo e visto che già da molti viene usata con MultiWii mi è sembrato utile aprire questo thread specifico dove riportare info e riferimenti per semplificare l'installazione di MegaPirate sulla CRIUS AIO Pro:

    Multiwii and Megapirate AIO Flight Controller w/FTDI (ATmega 2560)

    AIOP ALL IN ONE PRO Flight Controller V1.1 - Flight Control - RCTimer RC Plane Car MultiRotor APM and MultiWii Carbon Fiber Propeller Hobby Store


    Questo thread NON è una guida (non sono un esperto in materia) ma vuole rappresentare piuttosto un log delle attività di installazione con problemi incontrati e soluzioni trovate (o da trovare).

    Chi scrive questo post è un completo niubbo in MegaPiratologia e quindi metto in comune i passi che vengono fatti in modo che se altri vogliono seguire la medesima strada possono forse fare meno fatica evitando errori comuni e magari banali.

    Naturalmente sarebbe auspicabile che gli "esperti" presenti nel forum potessero dare il loro aiuto quando vedono che ci stiamo impantanando. Sarebbe anche simpatico se altri amici che stanno facendo la medesima strada potessero condividere qui le loro esperienze in modo da mettere in comune errori e soluzioni.

    ...via alla nuova avventura!

    Luciano
    TermicOne su youtube

  • #2
    Originariamente inviato da TermicOne Visualizza il messaggio
    Sul tema MegaPirate ho visto che ci sono un paio di thread interessanti:

    http://www.baronerosso.it/forum/mode...-settaggi.html

    http://www.baronerosso.it/forum/mode...gapirates.html

    dove ho trovato un sacco di informazioni utili e che consiglio di leggere a chi si vuole avvicinare a questo tema.

    Vista l'ampia disponibilità della scheda CRIUS AIO PRO a basso prezzo e visto che già da molti viene usata con MultiWii mi è sembrato utile aprire questo thread specifico dove riportare info e riferimenti per semplificare l'installazione di MegaPirate sulla CRIUS AIO Pro:

    Multiwii and Megapirate AIO Flight Controller w/FTDI (ATmega 2560)

    AIOP ALL IN ONE PRO Flight Controller V1.1 - Flight Control - RCTimer RC Plane Car MultiRotor APM and MultiWii Carbon Fiber Propeller Hobby Store


    Questo thread NON è una guida (non sono un esperto in materia) ma vuole rappresentare piuttosto un log delle attività di installazione con problemi incontrati e soluzioni trovate (o da trovare).

    Chi scrive questo post è un completo niubbo in MegaPiratologia e quindi metto in comune i passi che vengono fatti in modo che se altri vogliono seguire la medesima strada possono forse fare meno fatica evitando errori comuni e magari banali.

    Naturalmente sarebbe auspicabile che gli "esperti" presenti nel forum potessero dare il loro aiuto quando vedono che ci stiamo impantanando. Sarebbe anche simpatico se altri amici che stanno facendo la medesima strada potessero condividere qui le loro esperienze in modo da mettere in comune errori e soluzioni.

    ...via alla nuova avventura!

    Luciano
    Perfetto Luciano.......Sono della partita.
    Sergio
    (GTE - Torino)

    Commenta


    • #3
      Io mi sottoscrivo per rimanere aggiornato!

      Commenta


      • #4
        SW setup

        1 - scaricato Arduino ultima versione:
        Arduino - Software

        2 - scaricato MegaPirate NG ultima versione:
        MegaPirateNG_2.7_R4.zip - megapirateng - MegaPirateNG 2.7 R4 - MegaPirate Next Generation - Google Project Hosting

        3 - copiato il contenuto delle cartelle "libraries" e "tools" di MegaPirateNG nelle analoghe cartelle di Arduino

        4 - configurato il file APM_Config.h per la CRIUS AIO Pro

        codice:
        // Select your sensor board
        #define PIRATES_SENSOR_BOARD PIRATES_CRIUS_AIO_PRO_V1
        /*
        	PIRATES_ALLINONE
        	PIRATES_FFIMU
        	PIRATES_FREEIMU
        	PIRATES_BLACKVORTEX
        	PIRATES_FREEIMU_4 					// New FreeIMU 0.4.1 with MPU6000, MS5611 and 5883L
        	PIRATES_DROTEK_10DOF_MPU 		// MPU6000, MS5611 and 5883L
        	PIRATES_CRIUS_AIO_PRO_V1    // Crius AllInOne Pro v1
        */
        
        // RC configuration
        // Uncomment if you uses PPM Sum signal from receiver
        //#define SERIAL_PPM ENABLED
        
        #define TX_CHANNEL_SET	TX_mwi
        /*
        	TX_set1							//Graupner/Spektrum												PITCH,YAW,THROTTLE,ROLL,AUX1,AUX2,CAMPITCH,CAMROLL
        	TX_standard					//standard  PPM layout Robbe/Hitec/Sanwa	ROLL,PITCH,THROTTLE,YAW,MODE,AUX2,CAMPITCH,CAMROLL
        	TX_set2							//some Hitec/Sanwa/others									PITCH,ROLL,THROTTLE,YAW,AUX1,AUX2,CAMPITCH,CAMROLL
        	TX_mwi							//MultiWii layout													ROLL,THROTTLE,PITCH,YAW,AUX1,AUX2,CAMPITCH,CAMROLL
        */
        
        // Select your baro sensor
        #define CONFIG_BARO AP_BARO_MS5611_I2C
        /*
        	AP_BARO_BMP085_PIRATES
        	AP_BARO_MS5611_I2C
        */
        
        // Warning: COPTER_LEDS is not compatible with LED_SEQUENCER, so enable only one option
        #define COPTER_LEDS ENABLED     // New feature coming from ArduCopter
        //#define LED_SEQUENCER ENABLED   // Old Oleg's LED Sequencer, see leds.pde for more info
        
        #define MAX_SONAR_RANGE 400
        
        #define OSD_PROTOCOL OSD_PROTOCOL_NONE
        /*
        	OSD_PROTOCOL_NONE
        	OSD_PROTOCOL_SYBERIAN
        	OSD_PROTOCOL_REMZIBI  // Read more at: http://www.rcgroups.com/forums/showthread.php?t=921467
        */
        
        // For BlackVortex, just set PIRATES_SENSOR_BOARD as PIRATES_BLACKVORTEX, GPS will be selected automatically
        #define GPS_PROTOCOL GPS_PROTOCOL_AUTO
        /*
        	GPS_PROTOCOL_NONE 	without GPS
        	GPS_PROTOCOL_NMEA
        	GPS_PROTOCOL_SIRF
        	GPS_PROTOCOL_UBLOX     <<< Select this for UBLOX LEA-6 (CRIUS GPS boards and others)
        	GPS_PROTOCOL_MTK16
        	GPS_PROTOCOL_BLACKVORTEX
        	GPS_PROTOCOL_AUTO	auto select GPS
        */
        	
        #define SERIAL0_BAUD			 115200	// Console port 
        #define SERIAL2_BAUD			 38400	// GPS port
        #define SERIAL3_BAUD			 57600	// Telemetry (MAVLINK) port
        
        // New in 2.0.43, but unused in MegairateNG
        // MPNG: Piezo uses AN5 pin in ArduCopter, we uses AN5 for CLI switch
        #define PIEZO	DISABLED	
        #define PIEZO_LOW_VOLTAGE	DISABLED
        #define PIEZO_ARMING		DISABLED
        
        #define FRAME_CONFIG QUAD_FRAME
        /*
        	QUAD_FRAME
        	TRI_FRAME
        	HEXA_FRAME
        	Y6_FRAME
        	OCTA_FRAME
        	OCTA_QUAD_FRAME
        	HELI_FRAME
        */
        
        #define FRAME_ORIENTATION X_FRAME
        /*
        	PLUS_FRAME
        	X_FRAME
        	V_FRAME
        */
        Collegata la scheda al PC con USB e, dopo aver fatto scongiuri vari, ho compilato e caricato il sw.

        Per ora TUTTO OK!

        Luciano
        TermicOne su youtube

        Commenta


        • #5
          già subito una domanda: quando devo selezionare per esempio sensor board come intervengo? commento/decommento? già qui è diverso da multiwii dove sono tutte // e basta togliere // per attivare i sensori
          tutti i miei video
          tutte le mie recensioni

          Commenta


          • #6
            Mission Planner

            1 - scaricato il Mission Planner ultima versione:
            Downloads - ardupilot-mega - Official ArduPlane repository - Google Project Hosting

            2 - installato il Mission Planner e installati automaticamente gli aggiornamenti che il Mission Planner ha trovato da solo.

            Anche qui per ora TUTTO OK!
            File allegati
            TermicOne su youtube

            Commenta


            • #7
              Originariamente inviato da kamikazeta Visualizza il messaggio
              già subito una domanda: quando devo selezionare per esempio sensor board come intervengo? commento/decommento? già qui è diverso da multiwii dove sono tutte // e basta togliere // per attivare i sensori
              non devi toccare nulla...devi solo modificare le righe in modo che diventino come quelle in rosso. In pratica devi sostituire l'ultimo pezzo della riga con quello che scegli nelle righe che seguono.
              TermicOne su youtube

              Commenta


              • #8
                ok forse ho capito, devo copiare sulla stringa define il nome del sensore che utilizzo, giusto?


                edit: letto ora grazie termicone

                io installo su flyduino con imu varesano e poi su un clone che mi arriverà allinone. con e senza gps in i2c
                Ultima modifica di kamikazeta; 10th December 2012, 21:33.
                tutti i miei video
                tutte le mie recensioni

                Commenta


                • #9
                  Primo test

                  Collegata la scheda al PC e attivato Mission Planner.

                  Per collegare la scheda ho premuto CONNECT sul Mission Planner e....failed!

                  ....attenzione qui ci ho perso un sacco di tempo prima di scoprire che, diversamente da MultiWii, non si riesce a far funzionare la scheda "nuda" ...il caricamento si pianta a metà e non va avanti.

                  Collegato GPS e ricevente la scheda si è connessa e, come con la GUI MultiWii, vedo il mio quad che si muove in tutte le direzioni. Anche le barre dei canali della radio vengono rilevati e funziona tutto.

                  Già che c'ero ho fatto anche su Mission Planner la calibrazione della radio....che figata.

                  Il GPS non funziona ancora...non so se è perchè sono in casa o più probabilmente perchè è il vecchio GPS che perde la configurazione...proverò con quello nuovo.

                  Magnetometro e Barometro invece funzionano e attivano bussola, altimetro e variometro.
                  File allegati
                  TermicOne su youtube

                  Commenta


                  • #10
                    Originariamente inviato da TermicOne Visualizza il messaggio
                    Collegata la scheda al PC e attivato Mission Planner.

                    Per collegare la scheda ho premuto CONNECT sul Mission Planner e....failed!

                    ....attenzione qui ci ho perso un sacco di tempo prima di scoprire che, diversamente da MultiWii, non si riesce a far funzionare la scheda "nuda" ...il caricamento si pianta a metà e non va avanti.

                    Collegato GPS e ricevente la scheda si è connessa e, come con la GUI MultiWii, vedo il mio quad che si muove in tutte le direzioni. Anche le barre dei canali della radio vengono rilevati e funziona tutto.

                    Già che c'ero ho fatto anche su Mission Planner la calibrazione della radio....che figata.

                    Il GPS non funziona ancora...non so se è perchè sono in casa o più probabilmente perchè è il vecchio GPS che perde la configurazione...proverò con quello nuovo.

                    Magnetometro e Barometro invece funzionano e attivano bussola, altimetro e variometro.
                    Sono al tuo stesso punto.
                    In più ho il gps funzionante (non capisco a quanti hz) e soprattutto l'ho provato in volo dopo un primo setup dei pids "al banco"

                    I pids sono leggermente bassi. Dovrò alzarli e poi riprovare.

                    In acro mode dopo aver dato un comando e rilasciato lo stick, il quadricottero inverte la corsa, PERICOLOSISSIMO Non so se devo ancora alzare il valore P oppure se è un problema di I. Domenica al campo ho dimenticato di portare il computer per i settaggi.
                    Il Castellano says: Keep calm and make it spin-up

                    Commenta


                    • #11
                      Sottoscrivo, vorrei provarlo sulla scheda col gps ma non ho tempo
                      Master of Ciarpame
                      Bite my shiny metal ass

                      Commenta


                      • #12
                        Originariamente inviato da TermicOne Visualizza il messaggio
                        1 - scaricato Arduino ultima versione:
                        Arduino - Software

                        2 - scaricato MegaPirate NG ultima versione:
                        MegaPirateNG_2.7_R4.zip - megapirateng - MegaPirateNG 2.7 R4 - MegaPirate Next Generation - Google Project Hosting

                        3 - copiato il contenuto delle cartelle "libraries" e "tools" di MegaPirateNG nelle analoghe cartelle di Arduino

                        4 - configurato il file APM_Config.h per la CRIUS AIO Pro

                        codice:
                        // Select your sensor board
                        #define PIRATES_SENSOR_BOARD PIRATES_CRIUS_AIO_PRO_V1
                        /*
                        	PIRATES_ALLINONE
                        	PIRATES_FFIMU
                        	PIRATES_FREEIMU
                        	PIRATES_BLACKVORTEX
                        	PIRATES_FREEIMU_4 					// New FreeIMU 0.4.1 with MPU6000, MS5611 and 5883L
                        	PIRATES_DROTEK_10DOF_MPU 		// MPU6000, MS5611 and 5883L
                        	PIRATES_CRIUS_AIO_PRO_V1    // Crius AllInOne Pro v1
                        */
                        
                        // RC configuration
                        // Uncomment if you uses PPM Sum signal from receiver
                        //#define SERIAL_PPM ENABLED
                        
                        #define TX_CHANNEL_SET	TX_mwi
                        /*
                        	TX_set1							//Graupner/Spektrum												PITCH,YAW,THROTTLE,ROLL,AUX1,AUX2,CAMPITCH,CAMROLL
                        	TX_standard					//standard  PPM layout Robbe/Hitec/Sanwa	ROLL,PITCH,THROTTLE,YAW,MODE,AUX2,CAMPITCH,CAMROLL
                        	TX_set2							//some Hitec/Sanwa/others									PITCH,ROLL,THROTTLE,YAW,AUX1,AUX2,CAMPITCH,CAMROLL
                        	TX_mwi							//MultiWii layout													ROLL,THROTTLE,PITCH,YAW,AUX1,AUX2,CAMPITCH,CAMROLL
                        */
                        
                        // Select your baro sensor
                        #define CONFIG_BARO AP_BARO_MS5611_I2C
                        /*
                        	AP_BARO_BMP085_PIRATES
                        	AP_BARO_MS5611_I2C
                        */
                        
                        // Warning: COPTER_LEDS is not compatible with LED_SEQUENCER, so enable only one option
                        #define COPTER_LEDS ENABLED     // New feature coming from ArduCopter
                        //#define LED_SEQUENCER ENABLED   // Old Oleg's LED Sequencer, see leds.pde for more info
                        
                        #define MAX_SONAR_RANGE 400
                        
                        #define OSD_PROTOCOL OSD_PROTOCOL_NONE
                        /*
                        	OSD_PROTOCOL_NONE
                        	OSD_PROTOCOL_SYBERIAN
                        	OSD_PROTOCOL_REMZIBI  // Read more at: http://www.rcgroups.com/forums/showthread.php?t=921467
                        */
                        
                        // For BlackVortex, just set PIRATES_SENSOR_BOARD as PIRATES_BLACKVORTEX, GPS will be selected automatically
                        #define GPS_PROTOCOL GPS_PROTOCOL_AUTO
                        /*
                        	GPS_PROTOCOL_NONE 	without GPS
                        	GPS_PROTOCOL_NMEA
                        	GPS_PROTOCOL_SIRF
                        	GPS_PROTOCOL_UBLOX     <<< Select this for UBLOX LEA-6 (CRIUS GPS boards and others)
                        	GPS_PROTOCOL_MTK16
                        	GPS_PROTOCOL_BLACKVORTEX
                        	GPS_PROTOCOL_AUTO	auto select GPS
                        */
                        	
                        #define SERIAL0_BAUD			 115200	// Console port 
                        #define SERIAL2_BAUD			 38400	// GPS port
                        #define SERIAL3_BAUD			 57600	// Telemetry (MAVLINK) port
                        
                        // New in 2.0.43, but unused in MegairateNG
                        // MPNG: Piezo uses AN5 pin in ArduCopter, we uses AN5 for CLI switch
                        #define PIEZO	DISABLED	
                        #define PIEZO_LOW_VOLTAGE	DISABLED
                        #define PIEZO_ARMING		DISABLED
                        
                        #define FRAME_CONFIG QUAD_FRAME
                        /*
                        	QUAD_FRAME
                        	TRI_FRAME
                        	HEXA_FRAME
                        	Y6_FRAME
                        	OCTA_FRAME
                        	OCTA_QUAD_FRAME
                        	HELI_FRAME
                        */
                        
                        #define FRAME_ORIENTATION X_FRAME
                        /*
                        	PLUS_FRAME
                        	X_FRAME
                        	V_FRAME
                        */
                        Collegata la scheda al PC con USB e, dopo aver fatto scongiuri vari, ho compilato e caricato il sw.

                        Per ora TUTTO OK!

                        Luciano
                        Ciao Luciano

                        ottimo lavoro

                        per il gps che non funziona anzichè lasciare AUTO

                        "GPS_PROTOCOL_AUTO"

                        prova a metterci la riga(come hai fatto per la scheda e per il baro)a seconda del gps che monti e presumo sia questo(anche se da quello che hò capito il tuo è il NEO-6M):

                        "GPS_PROTOCOL_UBLOX <<< Select this for UBLOX LEA-6 (CRIUS GPS boards and others)"

                        Facci sapere

                        Diego

                        Commenta


                        • #13
                          Originariamente inviato da Elmessicano Visualizza il messaggio
                          Ciao Luciano

                          ottimo lavoro

                          per il gps che non funziona anzichè lasciare AUTO

                          "GPS_PROTOCOL_AUTO"

                          prova a metterci la riga(come hai fatto per la scheda e per il baro)a seconda del gps che monti e presumo sia questo(anche se da quello che hò capito il tuo è il NEO-6M):

                          "GPS_PROTOCOL_UBLOX <<< Select this for UBLOX LEA-6 (CRIUS GPS boards and others)"

                          Facci sapere

                          Diego
                          si si...ho provato anche con UBLOX ma non va.

                          Ho provato anche con il GPS CN-06 V2 ma non va neppure lui. Ho provato anche a cambiare baud rate sulla serial 2 senza successo.

                          Come avevo fatto con MultiWii devo collegare in parallelo un serial monitor e vedere se scheda e GPS si parlano...e cosa si dicono...poi vi faccio sapere...
                          TermicOne su youtube

                          Commenta


                          • #14
                            Ho trovato il modo per monitorare il dialogo tra GPS e CRIUS senza collegare un serial monitor.

                            Bisogna andare in TERMINAL e andare in test. Quindi con il comando rawgps si vedono le frame che si scambiano GPS e CRIUS. Devo riconfigurare il GPS e vedere se funziona.
                            TermicOne su youtube

                            Commenta


                            • #15
                              E' quasi mezzanotte ma ho vinto!

                              Usando il comando rawgps ho capito il problema e lo descrivo in modo che possa essere utile anche ad altri

                              GPS CN-06 V2
                              -----------------
                              Questo GPS ha una EEPROM e quindi mantiene la configurazione. Avevo collegato questo GPS a MultiWii e settato a 115200 binary...e quindi MegaPirate non lo vede. Dovrò resettarlo alla configurazione di default i modo che MegaPirate lo possa configurare (occorre configurare il sw per GPS UBLOX)


                              GPS CN-06 V1
                              -----------------
                              Questo GPS non ha EEPROM e quindi perde la configurazione dopo un giorno ritornando a 9600 NEMEA....configurazione buona per MegaPirate. Bisogna però ricordarsi che occorre accendere e spegnere il GPS due volte altrimenti non parte la comunicazione.

                              Configurato MegaPirate con GPS UBLOX (Grazie Diego!) acceso e spento due volte il vecchio GPS V1 ora Mission Planner mi fa vedere il protocollo tra GPS e scheda, il GPS fa il fix e sul Mission Planner appare casa mia!

                              Luciano
                              File allegati
                              TermicOne su youtube

                              Commenta

                              Sto operando...
                              X